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2.  ABOUT THIS DISSERTATION 
 
 
 
 
 
 
 
 
       This dissertation, will talk about expanding three-dimensional knowledge,  

commonly know as 3D. These computer graphics are made using programs to create 

perspective, which gives the appearance of depth even when viewed on a flat monitor.  

3D graphics make it possible to freely visualize every component object at will. 

  

           We can also create different textures, lighting and do a lot of difficult modifications 

with ease. One of the best programs which gives us this possibility, is Softimage XSI. It is 

quite a new product on the Polish computer market, which is why it’s not so well known yet. 

This dissertation will show that making basic static objects and models using this program, is 

an easy and enjoyable task. 
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3.  WPROWADZENIE  
 
 
 
 
     „Grafika - dzia
 informatyki zajmuj� cy si�  wykorzystaniem komputerów do generowania 
obrazów oraz wizualizacj�  rzeczywistych danych. Grafika komputerowa jest obecnie 
narz� dziem powszechnie stosowanym w nauce, technice, kulturze oraz rozrywce” patrz [7].  
   To ogólne  poj� cie grafiki zdefiniowane w encyklopedii ju�  w latach pi�� dziesi� tych. A jak 
ten dzia
 informatyki jest realizowany dzi� ? 
 
       Obecnie stworzenie dwuwymiarowego obrazu nie jest ju�  czym� , co wymaga mozolnych 
przygotowa�  ze strony grafików i artystów korzystaj� cych z technologii komputerowych. Z 
pocz� tkiem lat siedemdziesi� tych powsta
o wiele programów wspomagaj� cych takie dzia
ania 
i stosunkowo szybko mo� na si�  z nimi oswoi�  i w pe
ni wykorzystywa�  ich mo� liwo� ci. Ale z 
czasem wsparcie komputerowe dla dziedziny bardziej zawansowanej - jak�  niew� tpliwie jest 
grafika przestrzenna i animacja - by
o wielkim wyzwaniem dla twórców oprogramowania 
graficznego. Motywacja by
a tym wi� ksza, i�  komercyjne zapotrzebowanie g
ównie ze strony 
przemys
u filmowego oraz � wiata nauki stawia
o coraz wy� sze wymagania. Powstawa
y wi� c 
studia, które tworzy
y w
asne systemy do projektowania trójwymiarowych scen. Jednak� e 
momentem prze
omowym by
o wypuszczenie na rynek w 1984 roku pierwszego 
komercyjnego programu 3D do zastosowa�  produkcyjnych przez firm�  WAVEFRONT ( ang. 
czo
o fali). Da
o to pocz� tek wielkiej konkurencji, w nast� pstwie czego powstawa
y coraz 
ambitniejsze zespo
y a graficy mogli sobie dobiera�  coraz bardziej rozbudowane narz� dzia. 
W tym te�  duchu w 1986 roku, w Montrealu narodzi
a si�  firma SOFTIMAGE. Jej 
za
o� ycielem i w
a� cicielem by
 filmowiec Daniel Langlois. W dwa lata pó	 niej po 
konferencji  SIGGRAPH, Softimage sta
 si�  ju�  standardem w animacji przestrzennej. Tym 
niemniej prace nad t�  aplikacj�  trwa
y nieustannie, skutkiem czego po wielu modyfikacjach 
dotar
a do nas najnowsza wersja – XSI . 
 
       XSI to pot�� ne, obiektowo zorientowane � rodowisko. Interfejs jest ergonomicznie 
zaprojektowany, przystosowany do wielu zada� , przez co jest bardzo rozbudowany. Nie 
sposób wi� c, bez podstawowego przygotowania w pe
ni korzysta�  z olbrzymich mo� liwo� ci 
tego programu. Do tej pory na polskim rynku wydawniczym ukaza
o si�  niewiele pozycji 
odkrywaj� cych arkana Softimage’a. Jest to w Polsce stosunkowo nowy produkt, alternatywny 
do podobnej aplikacji o nazwie „3d Studio”. Jednak� e ocena u� ytkowników i firm testuj� cych 
programy graficzne wskazuje na coraz wy� sze notowania Softimage’a XSI. Warto wi� c 
pozna�  jego mo� liwo� ci i samemu oceni�  zarówno jego funkcjonalno��  jak i stopie�  trudno� ci 
w osi� ganiu zamierzonego celu. 
 
       Jak dot� d w rodzimych ksi� garniach ukaza
 si�  jedynie podr� cznik autorstwa Paw
a  
Krzemi� skiego – „Softimage XSI – podstawy” [1]. Wcze� niej graficy komputerowi mogli 
znale	�  pozycje autorstwa Barry Rufa i Gene Bodio t
umaczon�  przez Dariusza Makulskiego, 
zatytu
owan�  „Softimage 3D  podr� cznik dla grafików” [2].  
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        Istnieje wi� c potrzeba by poprzez takie � wiczenia jak te zawarte w tej pracy  przybli� y�  
znajomo��  tego narz� dzia, nie tylko grafikom ale i osobom amatorsko zajmuj� cym si�  
tworzeniem ciekawych obiektów trójwymiarowych, chc� cych da�  upust swojej fantazji i 
plastycznym zdolno� ciom.  
     
       Niniejsza praca jest równie�  uk
onem w stron�  wszystkich tych, którzy w XSI widz�  
wielowarstwowe pok
ady mo� liwo� ci graficznych i chc�  podj��  trud poznania przynajmniej 
podstawowych zada� . Te podstawy mog�  by�  przecie�  pocz� tkiem ciekawej przygody w 
� wiecie wirtualnej, trójwymiarowej przestrzeni. 
 
        Postaramy si�  w kilku rozdzia
ach pokaza�  podstawowe etapy tworzenia statycznych 
obiektów 3D, prezentuj� c jednocze� nie wykorzystywane funkcje, ich zakres i efektywno�� .  
 
         By w miar�  wygodnie realizowa�  zadania z modelowaniem obiektów, optymalnie jest 
dysponowa�  monitorem o minimalnej rozdzielczo� ci 1280×1024 – wtedy wszystkie funkcje 
dost� pne s�  z pozycji graficznego interfejsu. Mo� na te�  korzysta�  z interfejsu tekstowego, 
który jest osi� galny na górnym pasku zada� . Jednak wy� szy komfort mo� na osi� gn��  przy 
u� yciu dwóch monitorów, gdzie przy odpowiedniej konfiguracji mo� na oddzieli�  scen�  od 
narz� dzi. Pomocne te�  staje si�  u� ycie specjalnego urz� dzenie zwanego space ball, dzi� ki 
któremu mo� emy znacznie zoptymalizowa�  obs
ug�  programu.  
   
  Maj� c przygotowan�  platform�  mo� emy stopniowo wchodzi�  w tajemnice Softimage’a .  
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4.  INSTALACJA SOFTIMAGE XSI  
 
4.1  Rejestracja 
 
 

Program najlepiej pobra�  ze strony producenta: 

http://www.softimage.com/products/xsi/v5/foundation/register  [6], gdzie udost� pniona 

jest próbna wersja 30-dniowa  z prawie wszystkimi mo� liwymi funkcjami . 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
          
 Rys. 4.1  Pobieranie programu. 
 
 
Po wej� ciu na powy� sz�  stron�  wype
niamy wskazane pola rejestracji i wysy
amy nasze dane. 
Je� li nie pomin� li � my � adnego pola otrzymamy odpowied	  o tre� ci: 
 

 
 
Rys. 4.2  Odpowied�  po poprawnym wype
nieniu wszystkich wymaganych pól. 

Wype
niamy pola rejestracji 
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4.2 Klucz do pobrania programu 
 
Drog�  mailow�  otrzymujemy klucz do strony z której ju�  tylko pobieramy program o 
pojemno� ci 328 Mb. Wskazujemy miejsce gdzie ma by�  zapisana aplikacja i czekamy a�  
pobieranie zostanie uko� czone. 
 
 

 
 
      Rys. 4.3  Pobieranie produktu. 
 
 
 
4.3 Instalacja 
 
Instalacja przebiega standartowo i nie powinna nastr� cza�  wi� kszych problemów. 
Wskazujemy miejsce docelowe (najlepiej je� li jest to na dysku systemowym C).  
Po instalacji uruchamiamy program i zapoznajemy si�  z interfejsem, który jest w j� zyku 
angielskim.  
    W nast� pnym rozdziale zapoznamy si�  z podstawowymi funkcjami obs
ugi Softimage XSI. 
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5. UK	AD WSPÓ	RZ � DNYCH 
 
 
5.1  System reprezentacji przestrzeni 
 
W programie Sotimage XSI wykorzystywany jest klasyczny kartezja� ski system reprezentacji 
przestrzeni za pomoc�  trzech osi wspó
rz� dnych – X, Y, Z.  Pocz� tkiem uk
adu  jest punkt 
przeci� cia si�  wszystkich osi, który to punkt ma warto� ci 0, 0, 0. Wszystkie te osie 
wspó
rz� dnych maja reprezentacj�  graficzn�  w ka� dym oknie i oznaczone s�   kolorami  
przyporz� dkowanymi wed
ug kolejno� ci wyst� powania w oznaczeniu podstawowych 
kolorów sk
adowych    RGB = XYZ (red – czerwony – X; green – zielony – Y; blue – 
niebieski – Z). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                    Rys.5.1  Reprezentacja wspó
rz� dnych obiektu 
 
P
aszczyzny okre� lone przez osie XZ, XY, YZ tworz�  widoki, pomocne w poruszaniu si�  po 
trójwymiarowej scenie, które imituj�  na p
askim ekranie przestrze�  [10]. S�  to trzy 
p
aszczyzny rzutowania i maj�  nazwy:    Top (górna), Front (przód),  Wright ( prawa). 

 

 
 
 
 
 
 
 
 
 
 
Rys. 5.2  Widoki ortogonalne pokazuj�  scen�  z sze� ciu predefiniowanych 
              kierunków,  co u
atwia orientacj�  w przestrzeni 3D 
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5.2 Lokalny uk
ad wspó
rz� dnych 

Kiedy osie uk
adu wspó
rz� dnych powi�� e si�  z obiektem zamiast z przestrzeni� , wyznacz�  
one lokalny uk
ad wspó
rz� dnych (local coordinate system). Ten wzgl� dny system odniesie�  
rejestruje zmiany w przestrzeni lokalnej (local space), dotycz� ce pojedynczych obiektów 
podczas przemieszczania, obracania lub skalowania. Tak wi� c lokalny uk
ad wspó
rz� dnych 
definiuje przestrze�  obiektu, wykorzystuj� c wzgl� dny system odniesie�  

 

 

      P
aszczyzna YZ                                                             P
aszczyzna ZY     

��������������������������������������������������� ���������������������������� P
aszczyzna YX 

��������������������

�

 

       Rys.  5.3    G
ówna siatka konstrukcyjna jest zbudowana z trzech siatek  
                         konstrukcyjnych, po
o� onych w p
aszczyznach XY, YZ oraz ZX.  
 

5.3  Globalny uk
ad wspó
rz� dnych 

 
Kiedy osiom X, Y, Z narzuci si�  pewne sta
e po
o� enie i orientacj�  w przestrzeni, b� d�  one 
wyznacza�  bezwzgl� dny system odniesie� , zwany globalnym uk
adem wspó
rz� dnych (world 
coordinate system). System ten rejestruje po
o� enie wszystkich obiektów w przestrzeni 
globalnej.  

5.4  Rzutowanie równoleg
e 

Poniewa�  system rzutowania równoleg
ego przerysowuje obiekty, nie uwzgl� dniaj� c skrótów 
perspektywicznych, obiekty w widokach ortogonalnych i widokach u� ytkownika zawsze maj�  
prawdziwe wymiary, bez wzgl� du na to, jak daleko znajduj�  si�  one od obserwatora. 
Dodatkowo linie równoleg
e zachowuj�  równoleg
o�� , oboj� tnie jaka jest d
ugo��  ich 
rzutowania w przestrzeni. 

 
Inaczej dzieje si�  w przypadku widoków takich jak perspektywiczny (Perspective), z kamery 
(Camera), ze 	 ród
a � wiat
a (Light ) pos
uguj�  si�  rzutowaniem perspektywicznym . Obiekty 
w widoku perspektywicznym wydaj�  si�  male� , w miar�  oddalania si�  od obserwatora, a linie 
równoleg
e zbiegaj�  si�  do jednego punktu wraz ze wzrostem odleg
o� ci 
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5.5  P
aszczyzna - przestrze�  

W przestrzeni dwuwymiarowej para przecinaj� cych si�  linii zawsze wyznacza powierzchni�  
p
aszczyzny. Aby okre� li �  po
o� enie jakiegokolwiek punktu, le�� cego na takiej p
aszczy	 nie, 
wystarczy wiedzie� , jak�  odleg
o��  nale� y przeby�  wzd
u�  ka� dej z linii, pocz� wszy od 
punktu ich przeci� cia. 

Chc� c zdefiniowa�  przestrze�  trójwymiarow� , trzeba po prostu wprowadzi�  trzeci�  lini � , 
która nie b� dzie le� e�  na p
aszczy	 nie wyznaczonej przez dwie pierwsze linie. Aby zatem 
zlokalizowa�  po
o� enie punktu w przestrzeni 3D, nale� y dokona�  pomiaru odleg
o� ci wzd
u�  
trzech, a nie, jak poprzednio, wzd
u�  dwóch linii. 

W geometrii planarnej linie definiuj� ce przestrze�  okre� la si�  mianem osi X oraz osi Y. 
Punkt, w którym linie te przecinaj�  si�  ze sob� , nazywany jest � rodkiem uk
adu 
wspó
rz� dnych . Wspó
rz� dne � rodka uk
adu wspó
rz� dnych wynosz�  (0,0). 

W geometrii trójwymiarowej trzecia linia nazywana jest osi�  Z. Przebiega ona prostopadle do 
osi X i Y, przecinaj� c je w pocz� tku uk
adu wspó
rz� dnych. 
Wspó
rz� dne pocz� tku uk
adu wspó
rz� dnych w przestrzeni trójwymiarowej wynosz�  (0,0,0)  
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6.  OPIS SCENY I GRAFICZNEGO INTERFEJSU 
 
 
6.1  Modu
y sceny 
 
 
 
 
 

 
 
  
 
       Rys. 6.1  G
ówne modu
y sceny. 
 
        
  Ca
a scena podzielona jest na poszczególne widoki – z góry (Top), z przodu (Front), z boku 
(Right) oraz widok perspektywiczny z ruchomej kamery (Camera). 
W tym ostatnim widoku w celu sterowania podgl� dem, przytrzymujemy klawisz „o” i 
odpowiednio myszk�  z wci� ni� tym lewym przyciskiem, ustawiamy interesuj� cy nas k� t 
widzenia.  
 
Ponadto we wszystkich widokach mo� na pos
ugiwa�  si�  funkcj�  zbli� ania i oddalania obiektu 
poprzez przytrzymywanie klawisza „p” i odpowiednim sterowaniem myszk�  z wci� ni� tym 
lewym przyciskiem. Podobnie dzia
a funkcja ustawienia obiektu wzgl� dem � rodka sceny z 
u� yciem klawisza „z”.  
Widoki ortogonalne przestawiaj�  obiekty z kierunków tworz� cych k� t 90 stopni i nie 
uwzgl� dniaj�  deformacji zwi� zanej z oddaleniem od punktu obserwacji.  

panel ogranicze�  

panel transformacji 

panel edycji 

              Podstawowe widoki(widoki ortogonalne) 

                     obs
uga warstw 

wybór elementów sceny 

 

 narz� dzia aktywnego modu
u 

obs
uga animacji 

widok perspektywiczny 



 14 

W górnym pasku nad scen�  umieszczone s�  wszystkie narz� dzia i polecenia w postaci 
tekstowego menu, jako alternatywny sposób u� ycia. 
 
6.2  Panele  obs
ugi animacji 
 
 
                                                                                                                               
                                                                                                                                                                               
 
 
 
 
                                                              
 
                                           
 
                                                   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Rys. 6.2  Zak
adki z narz� dziami pod klawiszami numerycznymi   
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Zak
adki do bezpo� redniej obs
ugi animacji mo� na prze
� cza�   klawiszami numerycznymi : 
Model – „1” , Animate – „2” , Render –„3”, Simulate – „4”. W zale� no� ci od wybranej 
zak
adki dysponujemy narz� dziami  do tworzenia obiektu, nadawania mu ruchu oraz 
przeprowadzenia renderingu czyli nadawania cech fizycznych okre� lonym materia
om.     
Podstawowym narz� dziem w ka� dej z tych  zak
adek jest Get->Primitive. Mamy tu 
mo� liwo��  wstawienia prostych zdefiniowanych bibliotecznie obiektów, które mo� emy 
potem  dowolnie modyfikowa� . Po wybraniu okre� lonego obiektu pojawia nam si�  okno 
pozwalaj� ce zmienia�  podstawowe parametry wzgl� dem osi XYZ.  
Na ka� dym etapie realizacji projektu mo� emy klawiszem numerycznym „8” otworzy�  okno 
eksplorera gdzie  mo� emy  wy� wietli�  wszystkie obiekty na  scenie z ich cechami   (rys. 6.3).  
 
 
6.3  Okno Eksplorera 
 
 
  
                                                                                
 
 
 
                                                                               Podobiekty w strukturze projektu 
   
 
                                                                                                      
                                                                                      Okno w
a� ciwo� ci elementu warstwy 
 
 
 
 
 
  
 
 
 
 
 
      
   
 Rys. 6.3  Hierarchiczna struktura reprezentacji sceny w formie drzewa 
 
Naciskaj� c w powy� szym Eksplorerze prawym przyciskiem myszy na wybrany obiekt 
mo� emy wej��  w menu kontekstowe. Wybieramy:  
 
                   Properities->All Properities  
 
i otrzymujemy nowe okno Edytora w
a� ciwo� ci, umo� liwiaj � ce modyfikacje wszystkich 
parametrów zaznaczonego obiektu (rys. 6.4). Poprzez zmian�  ustawie�  suwaka lub 
wprowadzenie liczby z klawiatury dobieramy odpowiednie warto� ci dla poszczególnych 
w
a� ciwo� ci. Oprócz  wielko� ci geometrycznych istotnym parametrem jest wtórny podzia
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obiektu na siatk�  wielok� tów. Im bardziej ta siatka b� dzie zag� szczona tym bardziej 
precyzyjne b� d�  wyniki operacji modyfikuj� cych kszta
t danego obiektu. 
 
     Innym sposobem reprezentacji sceny w postaci drzewa i wzajemnych zale� no� ci jest okno  
Schematic (Rys. 6.5).  W postaci schematu przedstawione s�  poszczególne obiekty gdzie 
mo� na obserwowa�  jak dane operacje wp
ywaj�  na hierarchie zale� no� ci. Powy� sze okno 
otwieramy klawiszem numerycznym – „9” 
 
      Pozosta
e nie omówione elementy interfejsu przedstawimy podczas implementacji 
poszczególnych obiektów. Zapoznamy si�  z nimi poprzez ich konkretne wykorzystanie w 
� wiczeniach o ró� nej skali trudno� ci. 
 
 
 
 
 

Warto� ci promienia kuli 
 
 
 
 
 
                
 Ilo��  linii podzia
u 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                
 
 
 
 
      Rys. 6.4 Edytor w
a� ciwo� ci 
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        6.4   Schemat hierarchii                            
 
 
 
 
                                      Drzewo kamery g
ównej 
 
                                                                                                                   Zale� no� ci  
                                                                                                                   elementów obiektu 
 
 
 
 
 
 
                                                                                                                   
 
 
 
 
  
 
 
Rys. 6.5  Okno przedstawiaj� ce graficzny schemat hierarchii i zale� no� ci 
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7.  TWORZYMY GLOBUS 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
             Rys. 7.1  Globus  po renderingu. 
 
 
 
7.1  Kula 
 
                  
 
W tym � wiczeniu utworzymy obiekt przypominaj� cy globus. Na kul�  na
o� ymy tekstur�   z 
map�   � wiata. Dokonamy te�  odpowiedniego o� wietlenia.  
 
Pobieramy do naszej sceny obiekt kuli: 
Model->Get->Primitive->Poligon Mesh->Sphere 
 
Ustalamy optymalne parametry (promie�  na 5, linie podzia
u U=22, V=22). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
        Rys. 7.2   Parametry kuli. 
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7.2Tekstura 
 
Chc� c na
o� y�  tekstur�   na nasz  obiekt musimy importowa�  wcze� niej przygotowany obraz 
do naszego programu. Wchodzimy do funkcji: 
 
Tender->Get->Clip->Create Clip From File 
 
Otrzymujemy okno, dzi� ki któremu mo� emy wskaza�  � cie� k�  do przygotowanej tekstury: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
       Rys. 7.3   Okno plików z tapetami. 
 
Zaznaczamy odpowiedni plik z obrazem tekstury i potwierdzamy wybór – OK. Je� li 
korzystamy z plików w
asnych kopiujemy je do katalogu …\XSI_SAMPLES\Pictures. 
Pojawi si�  wtedy okno potwierdzaj� ce dodanie naszej tapety do standardowych tekstur. 
 
 
 
 
 
 
 
 
Rys. 7.4   Okno 
z parametrami  
nak
adania. 
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Tekstura pochodzi z pliku map_swiat_jpg. Zaznaczamy obiekt na którym ma si�  pojawi�  i 
przechodzimy do: 
 
Tender->Get->Texture->Clips->map_swiat_jpg 
 
 
 
 
Wynikiem jest pojawienie si�  okna: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                  Rys. 7.5   Wybór  sposobu na
o� enia tapety. 
 
Nast� pnie przyciskiem New zaznaczonym strza
k�  otwieramy menu dotycz� ce sposobu 
na
o� enia tekstury na zadany obiekt. W naszym przypadku wybieramy opcje Spherical 
(kulisty) aby dopasowa�  si�  do kszta
tu obiektu. 
 
 
Sprawdzamy teraz ju�  tylko poprawno��  na
o� enia tekstury przy pomocy renderingu: 
 
 
Render->Render->Preview->All Layers 
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Efekt powinien by�  podobny do tego poni� ej: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
               Rys. 7.6   Wynik ko� cowy. 
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   8.   MODELUJEMY KO	O Z � BATE  
     
 
 
Naszym zadaniem w tym � wiczeniu b� dzie stworzenie ko
a z� batego. Takie w
a� nie elementy 
wchodz�  w sk
ad bardziej z
o� onych mechanizmów, które wspó
pracuj�  ze sob�   tworz� c 
ruchomy model. Bazuj� c na  podstawowych obiektach Softimage XSI, dla zoptymalizowania 
pracy w tym przyk
adzie, pos
u� ymy si�  specjalnymi metodami odejmowania okre� lonych 
cz�� ci obiektu. Wykorzystamy funkcj�  Boolean, która dzia
a na  zasadzie algebry zbiorów. 
 
 
     

              
 

                 Rys. 8.1  Finalny widok z� batki 
 
8.1  Walec jako  „materia
” wyj � ciowy 
 
Do naszej sceny importujemy walec. Pos
u� y on nam jako „materia
” do tworzenia z� batki. 
Przechodzimy kolejno: 
  
  Model->Get->Primitive->Polygon Mesh ->Cylinder 
 
ustawiamy nast� puj� ce parametry : 
 

 
 
 
 
 
 
 
 
 
 
 
                 Rys. 8.2  Parametry walca 
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Teraz wprowadzamy na scen�  drugi walec, który pos
u� y nam do wykonania otworu w naszej 
z� batce. Ustawiamy parametry: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
              
            Rys. 8.3  Walec do wykonania otworu w � ebatce 
 
Zaznaczaj� c du� y cylinder – odejmiemy od niego wszystko to co jest wspólne z mniejszym 
walcem – przez co powstanie otwór: 
 
               Model ->Create->Poly Mesh->Boolean-> Difference 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                 
                        Rys. 8.4   Po wykonaniu otworu . 
 
8.2  Narz� dzie pomocnicze 
 
 
Nast� pnie musimy wyci��  z� by o odpowiednim kszta
cie. Stworzymy wi� c narz� dzie 
pomocnicze, które u
atwi nam wycinanie. Importujemy na scen�  najpierw sze� cian  
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Model->Get->Primitive->Polygon Mesh ->Cube 
 
który odpowiednio ustawiamy: Lenght 5, U 10, V 4, B 10. 
Wprowadzamy na scen�  dwa identyczne  walce, po to by za ich pomoc�  odpowiednio 
zamodelowa�  narz� dzie o profilu przestrzeni mi� dzy z� bami.  
      
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
              Rys. 8.5  Przygotowywanie profilu.    
 
Ustawiamy je symetrycznie wzgl� dem naszego sze� cianu, ustawiaj� c takie same bezwzgl� dne 
warto� ci translacji wzgl� dem osi sceny, podobnie jak na powy� szym rysunku.   Po wyci� ciu 
wspólnych cz�� ci z kostk�  poprzez operacje: 
 
           Model ->Create->Poly Mesh->Boolean->Difference 
 
zostanie  bry
a, któr�  b� dziemy wycina�  z� by. Pami� tajmy aby przed czynno� ciami wycinania 
pod� wietli�  obiekt którego pozosta
o��  ma zosta�  na scenie. Po wybraniu  drugiego obiektu 
wska	 nikiem „PICK” wybieramy opcj�  usuni� cia cz�� ci wspólnej  Delete(Freezes Op). 
 
 
 
 
  
 
 
 
 
 
 
                    Rys, 8.6  Okno usuwania pozosta
o� ci.    
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8.3  Funkcja Boolean 
 
Maj� c ustawione narz� dzie do wycinania profilu z� bów korzystamy podobnie jak wy� ej z 
funkcji Boolean, obracaj� c nasz walec wokó
 osi Y o sta
y k� t 30 stopni, co da nam 12 
z� bów.  
 
 
 

 
 
      Rys. 8.7   Wycinanie z� bów. 
 
Zanim jednak zaczniemy wycina�  pami� tajmy aby skopiowa�  figur�  pomocnicz� , gdy�  
skutkiem tej funkcji jest usuni� cie wszystkiego co pokrywa si�  z zaznaczonym w drugiej 
kolejno� ci obiektem. Przed wyci� cinaniem ostatniego z� ba nie musimy ju�  kopiowa�  
pomocniczej bry
y, gdy�  z� batka b� dzie ju�  kompletna. 
 
 
 
 
 
 
                                                                                                                      
                                                                                                            Obiekt wycinaj� cy 
 
 
 
 
 
 
 
 
 
 
 
               
                       Rys. 8.8  Tu�   po wyci� ciu. 
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Teraz ju�  tylko pozostaje na
o� y�  tekstur�  i zrenderowa� . Najlepszym modelem powierzchni 
b� dzie Anisotropic poniewa�  symuluje l� ni� ce obiekty tworz� c efekt wypolerowanego 
metalu: 
 
  Render->Get->Material->Anisotropic 
 
Ustawiamy parametry Shiny U, V=3 w celu zmniejszenia stopnia odbicia � wiat
a i 
dokonujemy (Renderingu)  
 
  Render->Render->Preview->All Layers 
 
 
Wstawiamy dodatkowe o� wietlenie w optymalnym miejscu, tak aby dobrze wyeksponowa�  
obiekt. Otrzymujemy ostateczny wygl� d naszego ko
a z� batego: 
 

 

 
 
Rys. 8.9  Gotowa z� batka. 
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9.   SZKLANY KIELICH  
 
Tematem tego � wiczenia jest modelowanie szklanego kielicha w otoczeniu z odpowiednim 
o� wietleniem, tak by zaakcentowa�  charakterystyczne cechy szk
a. Efektem ko� cowym 
b� dzie scena: 
 
 
 
 

 
 
Rys.  9.1  Szklany kielich. 
     
 
9.1   Krzywa Nurbs 
 
Zaczynamy od rysowania krzywej  Nurbs¹, która b� dzie tworzy
a kszta
t bocznej � cianki 
kielicha.   
W  zak
adce Model przechodzimy kolejno : 
  

Create->Curve->Draw Cubic by CVs 
 
Rysujemy mysz�  przekrój obiektu (najlepiej w oknie widoku „Front”), rozpoczynaj� c i 
ko� cz� c na osi x. Podwójna linia b� dzie modelowa
a grubo��  szk
a.(patrz Rys.9.2) 
 
 
 
 
 
 
¹NURBS (non-uniform rational B-splines) s�  to obiekty pomocnicze niewidoczne podczas renderingu, poniewa�  
nie maja grubo� ci, lecz to w
a�nie za ich pomoc�  definiuje si�  kszta
t powierzchni parametrycznych. S
u��  te�  
jako � cie� ki po których mog�  porusza�  si�  obiekty. 
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9.2  Przekrój � cianki  
 
 

      

 

 
 
                        Rys. 9.2  Przekrój � cianki tworzonego obiektu. 

 
Dokonujemy obrotu linii do ko
a osi OX. W tym celu maj� c pod� wietlon�  lini �  przechodzimy 
do opcji : 

 
  Model->Create->Poly. Mesh-> Revolution Around Axis 
 
Zaznaczamy opcj�  (Close U, Close V), dzi� ki temu nasza linia b� dzie domkni� ta do osi OXw  
punktach pocz� tkowym i ko� cowym. Zwi� kszamy parametry (U Span, V Span), uzyskamy 
przez to bardziej zaokr� glone kszta
ty . 
 
 

 

 
 
                       Rys.  9.3  Obiekt po obrocie przekroju wzgl� dem osi X. 
 
9.3  Pod
o� e 
 
 
Tworzymy pod
o� e pod nasz obiekt. Przechodzimy wi� c do opcji : 
   
  Model->Get->Primitive->Polygon Mesh->Grid 
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Zwi� kszamy powierzchni�  otrzymanej powierzchni (U Lenght, V Lenght). Mo� emy tak� e 
zwi� kszy�  ilo��  podzia
ów powierzchni (Subdivision U, V) 
 
 

 

 
                   
                        Rys. 9.4  Kielich na pod
o� u. 
 
 
O� wietlamy obiekt, przechodzimy kolejno do opcji : 

 
 Model->Light->Spot 

 
 

 
 
            Rys. 9.5   Parametry � wiat
a. 

 
 
 
Ustawiamy wed
ug swoich upodoba�  jak nasze � wiat
o ma o� wietla�  obiekt  (Color – kolor, 
Spread – rozprzestrzenianie si�  � wiat
a, Shadow – cie� , Attenuation – t
umienie � wiat
a, 
Photon –odbijanie � wiat
a) 



 30 

 
Pora zaj��  si�  teraz sceneri�  wokó
 kielicha.  Najpierw ustalimy tekstur�  na pod
o� e. W tym 
celu pod� wietlamy obiekt (Grid ) i przechodzimy kolejno : 

 
  
 
 
 
Render->Get->Texture->Cell 
 
 

    

 

 
 
       Rys. 9.6  Pod
o� e po nadaniu tekstury. 

 
 
Do dyspozycji mamy biblioteczne zasoby, m. in.:  Cell – ogniwo, Cloud – chmura ob
ok, 
Fabric – Tkanina, Wood – Drewno, itd.  Mo� emy dowolnie zamodelowa�  kolor 
poszczególnych opcji. Rys. 5.6 przedstawia podgl� d sceny po  wykonaniu: 
               
                           Render->Render->Preview->All Layers 
 
 
9.4  Shading �wiat
a. 
 
 
  Do celów na
o� enia tekstury  na nasz obiekt potrzebuje odpowiednich warto� ci trzech 
g
ównych parametrów (Reflectivity–odbijalno�� , Transparency-prze	 roczysto�� , 
Refraction-indeks refrakcji (za
amanie � wiat
a) ). 
  
Znaczymy nasz obiekt i przechodzimykolejno : 
 
  Render->Get->Material->Phong 
 
  
Ustalamy kolor na jasny  fiolet, tak jak ustawiono na Rys.5.7 
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                                           Rys. 9.7  Parametry szk
a. 
 
 
Przechodzimy do zak
adki  Transparency/Reflection (tutaj ustawiamy parametry 
odpowiednie dla prze	 roczysto� ci i odbijalno� ci  ) .Najwa� niejsze jest ustawi�  opcj�  (Index 
of Refraction = 1,9 , to jest warto��  odpowiadaj� ca szk
u ) . Ko� cowym rezultatem naszego 
projektu jest   poni� sza scena (Rys.9.8).  
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Rys. 9.8   Wynik ko� cowy. 
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10.  BUDUJEMY DOM  
 
Tematem tego � wiczenia b� dzie budowa prostego domku. Ca
o��  projektu b� dzie si�  sk
ada
a 
z 4 � wicze� . Przedstawiony zostanie kolejno sposób budowy poszczególnych elementów 
(� cian, drzwi, okien i dachu). Rozpoczynamy od budowy � cian. Aby prawid
owo wykona�  ten 
projekt nale� y � ci� le trzyma�  si�  warto� ci jakie nale� y wprowadza�  przy wszelkich 
transformacjach. 
 
10.1  Sze� cian – obiekt wyj� ciowy      
  
Wprowadzamy do naszej sceny sze� cian. Przechodzimy wi� c kolejno: 
 
  Model->Get->Primitive->Polygon Mesh->Cube 
 
Ustalamy nast� puj� ce parametry otrzymanego sze� cianu : 
Subdivisions – Lenght = 1, U = 30, Base = 30. 
Zmieniamy tryb wy� wietlania - Shaded 
 
 Shaded 

 
 
 Rys.10.1 Wprowadzenie sze� cianu na scen� . 
 
Z prawego paska wybieramy skalowanie i wpisujemy warto��  skalowania  
Z = 30, X = 30. 
 

 

 
                      
                             Rys.10.2  Skalowanie bry
y. 
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Pozwoli
o to na symetryczne rozci� gni� cie naszego pod
o� a pod dom. Mo� emy teraz 
budowa�  � ciany maj� c � wiadomo�� , � e wszystkie b� d�  tej samej grubo� ci i jednakowych 
wymiarów. 
     
10.2  Pod� wietlanie wielok� tów 
 
 Do budowy � cian musimy u� y�  funkcji która pozwoli nam na zaznaczanie poszczególnych 
poligonów w naszej podstawie. W tym celu z prawego paska zak
adki Select wybieramy tryb 
Polygon. Nast� pnie wybieramy narz� dzie którym b� dziemy znaczy�  poszczególne poligony. 
Równie�  z prawego paska wybieramy kolejno: 
   
  Select->Tools->Reycast, 
 
lub naciskamy klawisz F10. Przy kursorze myszki powinna si�  pojawi�  ma
a ikona oka. 
Maj� c wci� ni� ty klawisz Shift znaczymy poligony zgodnie z tym co pokazuje poni� szy 
rysunek. Przy pomocy funkcji translacji (o�  OY o warto��  +1) podnosimy poziom naszego 
domu w stosunku do pod
o� a. Dzi� ki temu zamodelujemy  fundamenty domu. 
 

 
                          
                                       
                                                                                                 Kolor wskazuj� cy zaznaczenie 
 
 
 
 
 
 
 
          Rys.10.3  Zaznaczenie poszczególnych poligonów. 
 
Kopiujemy zaznaczone poligony (naciskamy Ctrl+D ) i dokonujemy translacji wzgl� dem osi 
OY. Aby jednostka by
a równa w zak
adce  Transform  do warto� ci przy osi OY dodajemy 
(+1) naciskamy Enter (powtarzamy ten proces 2 razy ). 
 

 

 
 
                                     Rys.10.4  Translacja wybranych poligonów. 
 
 Mamy wybudowane fundamenty. Teraz przechodzimy do budowy � cian w tym celu musimy 
zaplanowa�  rozmieszczenie pokoi, drzwi, okien. � ci� gamy zaznaczenie poligonów w ca
o� ci  
i znaczymy tylko te, z których b� d�  budowane � ciany. Pod� wietlamy zgodnie z poni� szym 
wzorem: 
 

 



 34 

  

 

 
 
Rys.10.5 Zaznaczenie poligonów na � ciany. 

 
W puste miejsca b� d�  wstawione drzwi i okna. Dokonujemy podobnie kopiowania poligonów 
i translacji po osi OY = +1, czynimy tak 4 razy. Efektem naszej pracy b� d�  cz�� ciowo � ciany. 
 

 

 
 
                                         Rys.10.6   Translacja w gór�  (powstawanie � cian). 
 
Teraz musimy � ci� gn��  zaznaczenie poligonów tej cz�� ci  gdzie planujemy wstawi�  okna. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

         Rys.10.7 Zmiana pod� wietlenia poligonów na okna. 
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Ponownie dokonujemy kopiowania poligonów i translacji 5 razy wzgl� dem osi OY. 
Otrzymujemy nast� puj� cy efekt. 
 
10.3  Zamykanie przestrzeni nad otworami 
 
 
 
 
 

 
        
                                          
 
 
 
 
 
 
 
 
                         Rys.10.8 Translacja � cian na poziomie okien. 

 
Potrzebujemy teraz zamkn��  wszystkie okna i drzwi z góry, w tym celu dla ka� dego z okien i 
drzwi wykonujemy nast� puj� ce czynno� ci: 

- pod� wietlamy wszystkie zaznaczone poligony; 
-  znaczymy te które pos
u��  do zamkni� cia okien i drzwi zale� nie od tego czy � ciany s�  

z przodu z ty
u czy z boków. 
 

 
 
Pod� wietlamy nast� puj� co poligony (zarówno z przodu jak i z ty
u) 
 

 

 
           
                               Rys.10.9   Zaznaczenie poligonów przeznaczonych do zamkni� cia. 

 
 
Dokonujemy kopiowania zaznaczonych poligonów i translacji 4 razy tym razem wzd
u�  osi 
OX. To samo czynimy przy bocznych � cianach nie zapominaj� c o drzwiach wewn� trz 

 



 36 

budynku (w przypadku bocznych � cian translacja wzd
u�  osi OZ). Efektem tego jest poni� szy 
obiekt. 
 
 
 
 
 
 
                 
 
                Rys.10.10  Obiekt po  
                              wykonaniu 
                                nadpro� y.                                  

 
 
 
 
 

Znaczymy wszystkie kraw� dzie w celu dobudowania � cian i w konsekwencji stworzenia 
sufitu. Kopiujemy poligony i dokonujemy translacji 4 razy wzgl� dem osi OY. W ten sposób 
� ciany mamy wyko� czone. 
 

 

 
 
                                                Rys.10.11  � ciany po „rozbudowie”. 
 
Chwilowo zatrzymujemy dalsze budow�  obiektu w celu stworzenia okien i drzwi. Zapisujemy 
nasz projekt np. „Budujemy dom”(File->Save As...). W nowym projekcie b� dziemy 
modelowa�  drzwi. Czynimy tak ze wzgl� du na szybko��  pracy. W nowym projekcie b� d�  
tylko drzwi co znacznie odci�� a procesor z oblicze� . 
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11.   DRZWI  
 
Tematem tej lekcji b� dzie stworzenie drzwi do naszego projektu „Budujemy dom”.  
 

 

 
  
                                   Rys. 11.1  Drzwi po nadaniu tekstury. 
      
11.1  Sze� cian 
 
W celu stworzenia drzwi ponownie na pocz� tek wprowadzamy do sceny prosty  
1×1×1 sze� cian. Przechodzimy kolejno: 
 
  Model->Get->Primitive->Polygon Mesh->Cube 
 
Ustawiamy nast� puj� ce parametry dla kostki i dokonujemy skalowania : 
 

 
 
                      
 
 
 
 
 
 
 
 
 
  Rys. 11.2  Parametry kostki. 
 
Przechodzimy w tryb Polygon. Zaznaczamy Wszystkie poligony z przodu i z ty
u  w celu 
zwi� kszenia podzia
ów.  Przechodzimy do opcji : 
 
  Model->Modify->Poly Mesh->Subdivide Polygons/Edges 
 
lub naciskaj� c kombinacj�  klawiszy Shift+D. Zwi� kszamy poziom podzia
ów poligonów o 
warto��  2. 
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                         Rys. 11.3  Zwi� kszenie liczby poligonów. 

 
11.2  Translacja wielok� tów 
 
W dalszej cz�� ci b� dziemy modelowa�  wygl� d drzwi. Kasujemy pod� wietlenie poligonów. 
Nast� pnie pod� wietlamy je zgodnie z poni� szym rysunkiem: 
 

 

 
 
                                             Rys. 11.4   Odznaczanie poligonów. 

 
Dokonujemy translacji wzgl� dem osi OZ o warto��   0.1. Podobnie czynimy z drug�  stron�  z 
tym, � e wpisujemy warto��   –0.1. Powinni� my otrzyma�  nast� puj� cy obiekt : 
 

 

  
 
                                                    Rys. 11..5  Profilowanie obiektu. 
 
Przechodzimy w tryb Edge (linie) i zaznaczamy z jednej strony lini�  przechodz� c�  przez 
� rodek drzwi w pionie. 
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                                                Rys.11.6   Podzia
 w pionie. 
 
Wracamy do trybu Polygon. Zaznaczmy poligony znajduj� ce si�  na � rodku drzwi w pionie 
(przyleg
e do linii, któr�  wcze� niej zaznaczyli� my ). Zwi� kszamy podzia
 poligonów przez 
naci� ni� cie Shift+D dwukrotnie. Po czym wracamy w tryb Edge i dokonujemy transformacji 
po osi OZ o warto��  +0.1. Identycznie post� pujemy z drug�  stron�  drzwi Efektem naszej 
pracy powinien by�  nast� puj� cy obiekt: 
 

 

 
 
                                               Rys. 8.7   Tworzenie zag
� bienia. 

 
Powsta
e rowki b� d�  modelowa
y miejsce gdzie drzwi si�  zamykaj� . Pozostaje nam budowa 
klamek i na
o� enie tekstur na nasz obiekt. 
 
      
11.3  Tworzenie klamek 

  
 
W celu zbudowania klamek pos
u� ymy si�  „Krzywymi Nurbs”. Przechodzimy kolejno do 
opcji : 
 

Model->Create->Curve->Draw Cubic by CVs 
 
I rysujemy w widoku „Top” kszta
t klamki. Rozmiar jest dowolny. Poprzez skalowanie 
dopasujemy wielko��  klamki. 
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                                             Rys. 11.8   Linia okre� laj� ca profil klamki. 

 
W celu stworzenia grubo� ci klamek tworzymy ko
o które na
o� ymy na nasz�  lini �  ko
o 
powinno mie�  wymiary proporcjonalne do wielko� ci linii. Przechodzimy kolejno : 
 
  Model->Get->Primitive->Circle 
 
Zmniejszamy warto��  promienia do 0,4 i dokonujemy na
o� enia ko
a na lini� . W tym celu 
maj� c zaznaczone ko
o przechodzimy do opcji : 
 
  Model->Create->Surf. Mesh->Extrusion Along Curve  
 
Pojawia si�  napis Pick przy kursorze myszki. Naciskamy na obiekt linii co powoduje 
powstanie tunelu. Ustawiamy parametry zgodnie z poni� szym rysunkiem . Efektem naszej 
pracy jest nast� puj� cy obiekt: 
 

    

 

 
 
                                Rys. 11.9  Klamka w fazie tworzenia. 
 
Aby usun��  ko
o oraz lini�  ze sceny naciskamy przycisk (Delete(Freezes Op)) zaznaczony 
przez strza
k�  w poprzednim rysunku. Teraz musimy zeskalowa�  nasz�  klamk�  do rozmiarów 
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drzwi. Dokonujemy skalowania po wszystkich osiach o jednakow�  warto�� , w tym przypadku 
warto��  skalowania wynios
a 0,07. Ustawiamy za pomoc�  transformacji nasz obiekt w 
odpowiednie miejsce tak aby powsta
a ca
o�� . Kopiujemy obiekt i symetrycznie ustawiamy 
po drugiej stronie drzwi co daje nast� puj� cy efekt. 
 

 

 
 
              Rys. 11.10  Umiejscowienie klamek. 
           

Mo� emy skopiowa�  jeszcze raz klamki i umie� ci�  po drugiej stronie drzwi w tym celu 
zaznaczamy obie klamki kopiujemy je. Nast� pnie dokonujemy rotacji wzg
edem osi X i 

przesuwamy w odpowiednie miejsce: 
 

 

 
 
                                               Rys. 11.11  Kompletowanie klamek. 
 
11.4  	 � czenie w hierarchie 
 
Aby nasz obiekt stanowi
 ca
o��  i przy przesuwaniu drzwi nasze klamki si�  nie zgubi
y 
wprowadzimy „Hierarchi�  rodzicielsk� ” (parent tool). W tym celu zaznaczamy obiekt drzwi 
i wyszukujemy z prawego paska przycisk Constrain->Patent. Po naci� ni� ciu pojawia si�  
napis Pick przy kursorze myszki. Kolejno zaznaczany wszystkie klamki co powoduje � e 
obiekty stanowi�  ca
o�� . Dokonuj� c jakiejkolwiek transformacji na obiekcie drzwi powoduje 
transformacje w pozosta
ych obiektach (nie na odwrót).  
 
 
      
 
                                                                                                   Obiekt „klamka” dziedziczy  
                                                                                                   w
a� ciwo� ci obiektu „drzwi” 
Rys. 11.12   Drzewo  
dwóch obiektów. 
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W dalszej cz�� ci dokonamy na
o� enia tekstur na nasz obiekt w tym celu przechodzimy w tryb 
Polygon i pod� wietlamy nast� puj� ce wielok� ty zarówno z ty
u jak i z przodu drzwi : 
 

 

 
 
Rys. 11.13   Odznaczenie poligonów. 

 
11.5  Nak
adanie tekstury 
 
 
W celu nadania tekstury przechodzimy w lewym pasku do zak
adki Render (klawisz 3). 
Uruchamiamy kolejno  opcje : 
 
  Render->Get->Texture->Wood 
 

Pojawiaj�  si�  dwa okna z opcjami (Material Wood, Material Phong). Ustalamy kolor 
wed
ug w
asnego uznania.  Dokonujemy renderingu by zobaczy�  efekt ustawie�  : 

 
  Render->Render->Preview->All Layers  
 
Otrzymujemy nast� puj� cy efekt: 
 

 

 
 
                Rys. 11.14  Nak
adanie tekstury na obrze� ach drzwi. 
 
Kasujemy pod� wietlenie poligonów, wybieraj� c opcj�  z prawego paska Select->Deselect All. 
Znaczymy teraz pozosta
e wielok� ty (te na które nie na
o� yli � my tekstury). Nadamy im nieco 
inny kolor (ja� niejszy) tak aby drzwi si�  lepiej prezentowa
y. 
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 Rys. 11.15  Drzwi w podczas nadawania tekstury cz�� ci � rodkowej. 

 
Pozostaje nam tylko jeszcze nada�  tekstur�  dla klamek. Pos
u� ymy si�  w tym celu zwyk
ym 
kolorem. Znaczymy wszystkie klamki i nadajemy kolor poprzez przej� cie do opcji : 
 
  Render->Get->Material->Simple Phong  
 
Ustawiamy kolor na � ó
ty co sprawi, � e klamki b� d�  wygl� da
y jak z
ote. Ko� cowy efekt 
naszej pracy wygl� da tak : 
 

 

  
 
                       Rys. 11.16   „Z
ocenie” klamek. 
 
Drzwi mamy gotowe, nadszed
 wi� c czas na zamodelowanie okna. Dokonamy tego podobnie 
jak przy modelowaniu drzwi. Zapisujemy nasz projekt np. nazywaj� c go „Drzwi do domu”. 
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12.   OKNO 
 
 

 
Przy budowie okien b� dziemy post� powa�  podobnie jak z drzwiami 

 
 
 
 
 
 
 
 
 
 
 
Rys. 12.1   Okno. 

  
            Tworzymy nowy projekt i ponownie wprowadzamy elementarny sze� cian na scen� : 
 
  Model->Get->Primitive->Polygon Mesh->Cube 
 
Ustawiamy odpowiednie wymiary kostki i liczb�  podzia
ów oraz dokonujemy skalowania 
zgodnie z tym co pokazuje poni� szy rysunek. Wymiary nie s�  przypadkowe gdy�  
pos
ugujemy si�  jednostk�  zgodn�  z projektem podstawowym. Dzi� ki temu nasze okna i 
drzwi b� d�  idealnie pasowa
y do zamodelowanych w poprzednich projektach otworów. 
 

 

 
 
                   Rys. 12.2   Ustawianie parametrów „Cube” 
 
Przechodzimy w tryb Polygon i zaznaczamy wszystkie wielok� ty z przodu i z ty
u naszego 
obiektu a nast� pnie dokonujemy zwi� kszenia liczby podzia
ek za pomoc�  znanej ju�  opcji 
Subdivide Polygons/Edges, lub przez naci� ni� cie kombinacji klawiszy (Shift+D) dwa razy.  
 
 
12.1  Tworzenie szyby 

 
Zaznaczamy poligony (zarówno z ty
u jak i z przodu), które b� d�  s
u� y
y nam jako szyby w 
naszym oknie: 
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Rys. 12.3  Okno po odznaczeniu poligonów. 

 
Naszym zadaniem b� dzie ustawienie takich warto� ci Prze	 roczysto� ci (Transparency) aby 
zamodelowa�  szk
o. Przechodzimy do opcji: 
 
  Render->Get->Material->Phong 
 
Pojawia si�  okno z opcjami tekstury, przechodzimy wi� c do zak
adki 
Transparency/Reflection i ustawiamy parametry prze	 roczysto� ci na 0,95 (warto��  dla 
szk
a). Nast� pnie zaznaczone wielok� ty skalujemy o warto��  0,1 wzd
u�  osi OZ. 
Otrzymujemy nast� puj� cy efekt : 
 

 

 
 
               Rys. 12.4  Ustalanie parametrów szyby.          
 
12.2  Profilowanie kszta
tu ramek 
 
 
Okno mamy ju�  prawie gotowe, potrzebujemy teraz zrobi�  rowek w pionie przez � rodek okna 
podobnie jak to robili� my z drzwiami. Przechodzimy w tryb Edge i znaczymy � rodkow�  lini �  
w pionie.  Wracamy w tryb Polygon i znaczymy wielok� ty po� rodku okna przyleg
e do linii. 
Zwi� kszamy liczb�  podzia
ek (Shift+D)dwukrotnie. Po czym znów wracaj� c w tryb Edge 
dokonujemy translacji naszej � rodkowej linii wzgl� dem osi OZ o warto��  -0,1, podobnie 
robimy z drug�  stron�  okna z t�  ró� nic� , � e o warto��  dodatni�  (+0,1). Takie zmiany  trybów z 
Edge na Polygon zwi� ksza efektywno��  pracy. Je� li przed zaznaczeniem � rodkowej linii 
dokonaliby� my zwi� kszenia liczby podzia
ów w trybie Polygon mieliby� my problemy z 
zaznaczeniem tej linii.  
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    Rys.12.5  Podzia
 okna na dwie po
ówki. 
 
Pozostaje nam na
o� enie tekstury na obramowanie okna, w tym celu zaznaczamy 
odpowiednie wielok� ty zarówno z jednej jak i drugiej strony i  przechodzimy kolejno : 
 
  Render->Get->Texture->Wood 
 
Niech nasze okna b� d�  mia
y ramki z drewna podobnego do drzwi. Aby nie m� czy�  si�  z 
zaznaczaniem poszczególnych wielok� tów pos
u� ymy si�  jednym z dost� pnych narz� dzi 
które pozwala na zaznaczenie wi� kszej ilo� ci poligonów: Shift+F10. 
 

 

  
 
                         Rys. 12.6   Odznaczenie odpowiednich poligonów. 
 
12.3  Kopiowanie klamek z innego projektu 
 
Aby okno by
o kompletne, tworzymy klamki. 
 eby jednak tworzy
y podobny styl - zrobimy 
je na wzór tych z drzwi. Skopiujmy wi� c klamk�  z poprzedniej sceny, nieco je modyfikuj� c. 
 
      
 
Zapisujemy nasz projekt jako „Okno do domu”. Nast� pnie otwieramy inny projekt - w 
naszym  przypadku „Drzwi do domu”. Przechodzimy do opcji: 
 

File->Merge  
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Opcja ta pozwala na przeniesienie zawarto� ci z innego projektu do aktualnego otwartego. Po 
naci� ni� ciu przycisku pojawia si�  okno z projektami. Zaznaczamy interesuj� cy nas projekt, 
który chcemy przetransportowa�  i naciskamy przycisk OK . 
 

 

 
 
                                    Rys. 12.7  Okno projektów. 
 
Mamy ju�  w jednym projekcie zarówno drzwi jak i okno. Nale� y pami� ta�  � e przenoszona 
jest ca
a scena do otwartego projektu i powinno si�  usuwa�  zb� dne � wiat
a, w które 
standardowo scena jest wyposa� ona. W tym celu naciskamy klawisz 8 co powoduje 
pokazanie si�  okna Explorer . 
 

 

 
 
                                     Rys. 12.8   Okno eksplorera. 
 
W tym momencie mamy 2 � wiat
a (Light ). Je� li w scenie jest wiele 	 róde
 � wiat
a powa� nie 
spowalnia to proces renderingu, czego nale� y unika� . W naszym przypadku usuniemy jedno 
ze � wiate
. Zaznaczamy zb� dne � wiat
o i naciskamy klawisz Delete. Mo� emy teraz skopiowa�  
klamki  drzwi i odpowiednio je ustawi� . 
 



 48 

 

 
  
                                                 Rys. 12.9  Dodawanie klamek. 
 
12.4  	 � czenie elementów sceny 
 
 
W nast� pnej etapie nauczymy si�  
� czy�  elementy sceny. Jest to przydatne w sytuacji kiedy 
jeden obiekt sk
ada si�  kilku elementów. W tym celu naciskamy klawisz „8” pojawia si�  okno 
Explorer , gdzie rozwijamy nasze drzewo z poszczególnymi elementami sceny. 
 

 

  
 
                                             Rys. 12.10  Okno z elementami sceny. 
 
Strza
ka wskazuje na klamki (Surfmsh). Surfmsh 5 i 6 nale��  do okna. Za pomoc�  kursora 
myszki przeci� gamy je na obiekt Cube (okno). W ten sposób te obiekty stanowi�  jedn�  
ca
o�� . Mo� na dokonywa�  ich translacji, nie gubi� c � adnego elementu. 
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                                               Rys. 12.11  Kolejno��  hierarchii sceny. 
 
Strza
ki pokazuj�  jak powinna wygl� da�  hierarchia naszej sceny. Usuwamy drzwi i 
zapisujemy. 
 

 

 
 
                                             Rys. 12.12   Okno po renderingu. 
 
 Zamykamy projekt. W dalszej cz�� ci b� dziemy wstawia�  okna i drzwi w odpowiednie 
miejsca i budowa�  dach. 
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13.   DACH 
 
 
Celem � wiczenia b� dzie po
� czenie wszystkich stworzonych elementów w jedn�  ca
o�� . 
  
 

 
 
      
 
 
 
 
 
 
 
 
                 Rys. 13.1  Dom w perspektywie 
 
Maj� c otwarty nasz projekt „Budujemy dom” za pomoc�  znanej ju�  funkcji File->Merge 
importujemy projekt „Budujemy drzwi” i „Budujemy okno”. Usuwamy zb� dne � wiat
a i 
rozpoczynamy kopiowanie oraz wstawianie okien i drzwi w wyznaczone przez nas miejsca, 
za pomoc�  translacji wzgl� dem okre� lonych osi. Nasze obiekty powinny idealnie pasowa�  do 
wyznaczonych przez nas miejsc. Jedynie wewn� trzne drzwi nale� y skalowa�  wzgl� dem 
szeroko� ci a nast� pnie wstawi�  w odpowiednie miejsca. 
 
Przed budow�  dachu powinni� my stworzy�  sufit post� pujemy podobnie jak przy budowie 
� cian. Przechodzimy w tryb Polygon. Zaznaczamy poszczególne poligony kopiujemy i 
dokonujemy translacji o warto� ci (+1 oraz -1) do czasu stworzenia ca
ego sufitu. 
 

  
 
 
                                          
 
 
 
 
 
 
 

                             Rys. 13.2   Dodanie sufitu do istniej� cych � cian. 
 
13.1  Wykorzystanie walca 
 
 
Teraz przechodzimy do budowy dachu. Do tego celu u� yjemy cylindra. Jest to do��  wygodny 
sposób, gdy�  przy minimalnej ilo� ci linii podzia
u wzgl� dem w
asnej osi walca (U=3) – 
otrzymujemy bry
�  w postaci graniastos
upa o podstawie trójk� ta. 
Wybieramy kolejno: 
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Model->Get->Primitive->Polygon Mesh->Cylinder 
 
 Dokonujemy ustawienia odpowiednich wielko� ci dla cylindra oraz szeregu transformacji 
(translacji, rotacji i skalowania) Wpisujemy dok
adnie takie warto� ci jak podaje poni� szy 
rysunek (budowanie obiektu równoleg
e do osi XYZ  u
atwia prac�  przy kolejnych 
elementach sceny, nale� y tak� e pami� ta� , � e operacje translacji i rotacji by
y wykonane przy 
globalnym uk
adzie wspó
rz� dnych a skalowanie przy lokalnym uk
adzie wspó
rz� dnych ): 
 
 

 
 
        Rys. 13.3  Tworzenie dachu budynku. 
 
W dalszej cz�� ci nieco zmniejszymy stromo��  naszego dachu, w tym celu przechodzimy w 
tryb Edge (linie) i zaznaczamy górne kraw� dzie naszego dachu po czym dokonujemy 
translacji wzgl� dem osi OY do warto� ci –10. 

 

 
 
                                Rys. 13.4  Operacja sp
aszczania dachu. 
 
Przechodzimy w tryb Polygon i zaznaczamy ca
�  powierzchni�  dachu i dokonujemy 
zwi� kszenia liczby poligonów Shift+D cztery razy.   
 

 

 
 
 Rys. 13.5  Zwi� kszenie liczby poligonów. 
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Naszym materia
em b� dzie blacha. Przechodzimy w tryb Point (punkt) i zaznaczamy co drugi 
rz� d punktów w celu zrobienia fa
d. Fa
dy robimy poprzez translacj�  wszystkich 
zaznaczonych punktów (z obu stron dachu) po osi Y o warto��  +0,3. 
 
13.2  Profilowanie pokrycia 
 

 
 
 
 

 
                                               
 
 
 
 
 
 
                            Rys. 13.6   Fa
dowanie blachy. 
 
W trybie Edge zaznaczamy linie które nie stanowi�  platformy dachu i dokonujemy translacji 
wzgl� dem osi X o warto��  +(-)1 (w zale� no� ci od strony), w celu zrobienia wci� cia pod dach. 
 

 

 
 
                                            Rys. 13.7  Modelowanie wci� cia pod dach. 
 
Prosty domek prawie gotowy, pozosta
o nam jeszcze  dorobi�  schody i komin. W celu 
zrobienia schodów wystarczy zaznaczy�  odpowiednie wielok� ty, skopiowa�  je i dokona�  
translacji wzd
u�  osi OZ o warto��  +1. 
 
13.3  Modelowanie komina 
 
Aby zrobi�  komin musimy ponownie rozpocz��  od sze� cianu. 
 

Model->Get->Primitive->Polygon Mesh->Cube  
 
Odpowiednio go przeskalowa�  i umie� ci�  na w
a� ciwym miejscu  
 

 



 53 

 

 
                                     
                                   Rys. 10.8   Tworzenie komina. 
 
Odpowiednio zwi� kszamy liczb�  wielok� tów na obrze� ach szczytu komina i dokonujemy 
kopiowania i translacji wzgl� dem osi OY o warto�� : –3  
 

 

 
 
                                           Rys. 13.9   Szczegó
y komina. 
 
Pozosta
o nam tylko nada�  tekstury i pokolorowa�  obiekty. Ca
o��  b� dzie si�  sk
ada
a z 
zaznaczania poszczególnych wielok� tów i nak
adania odpowiednich tekstur i kolorów. 
    
13.4  Nak
adanie tekstury  
      
Zaczniemy od na
o� enia tekstury na nasz g
ówny budynek . Zaznaczamy obiekt budynku i  
nak
adamy kolor  
 
  Render->Get->Material->Phong  
 
Ustawiamy kolor na jasno niebieski (takiego koloru b� d�  � ciany w domu, u
atwi to 
kolorowanie poszczególnych � cian) 
 

 

 
                                          Rys. 13.10   Nak
adanie wybranych kolorów. 
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Na tym etapie nie jest to zbyt klarowne ale, w dalszej cz�� ci b� dziemy znaczy�  odpowiednie 
poligony i nak
ada�  inne kolory i tekstury. W celu wykonania pod
o� a tworzymy nowy obiekt 
Grid . Przechodzimy kolejno: 
 
  Model->Get->Primitive->Polygon Mesh->Grid  
 
Odpowiednio ustawiamy rozmiary i liczb�  podzia
ów. 
 

 

 
 
                                 Rys. 13.11  Parametry do pod
o� a domu. 
 
Dokonujemy translacji wzgl� dem osi OZ o warto��  1 i deformacji powierzchni. W celu 
zamodelowania nierówno� ci pos
u� ymy si�  funkcj�  Randomize, gdzie losowo zostanie 
sfa
dowana p
aszczyzna: 
 
  Model->Modify->Deform->Randomize  
 
Ustalamy odpowiednie parametry graniczne naszej deformacji  
 

 

 
 
                                   Rys. 13.12  Dobór parametrów deformacji. 
 
Nak
adamy tekstur�  na nasz obiekt. Przechodzimy kolejno  
 
  Render->Get->Texture->Terrain  
 
Ustawiamy odpowiednie kolory co daje efekt: 
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                    Rys. 13.13  Pod
o� e imituj� ce trawnik. 

 
Schody i podmurówk�  zrobimy z marmuru. Zaznaczamy odpowiednie wielok� ty naszego  
domu i przechodzimy do opcji : 
 
  Render->Get->Texture->Marble  
 
Modyfikujemy kolor i otrzymujemy : 
 
 

 
Rys. 13.14  Wyko� czenie dolnej cz�� ci � cian i schodów. 

 
Pozosta
y nam � ciany. Zaznaczamy wszystkie poligony naszych � cian i nadajemy im wybrany 
 kolor, przechodzimy kolejno: 
 
   
 
              Render->Get->Material->Lambert 
 
 
Shading typu lambert powoduje � e kolor jest bardziej matowy  
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Rys. 13.15  „Malowanie � cian”. 
 
 
Na dach na
o� ymy kolor ciemno zielony  
 
   
Render->Get->Material->Phong  
 
 
 
 
Ustawiamy warto� ci kolorów jak poni� ej i otrzymujemy: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
  Rys. 13.16  Dach po nadaniu barwy zieleni. 
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Pozostaje nam na
o� enie kolorów na boki dachu poddasze i komin. Zaznaczamy odpowiednie 
poligony i nadajemy kolory zgodnie z naszym upodobaniem. Ostatecznie nasz projekt b� dzie  
si�  prezentowa
 nast� puj� co: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Rys. 13.17  Gotowy projekt domu. 
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14.  Zako� czenie 
 
 
 
 
        Kolejne etapy pracy z programem graficznym SOFTIMAGE XSI daj�  nam coraz 

wi� ksze do� wiadczenie  i przynosz�  coraz wi� ksz�   sprawno��  w stosowaniu w
a� ciwych, 

optymalnych metod post� powania w tworzeniu poszczególnych obiektów. Przyk
ady które 

zosta
y opracowane w tych kilku rozdzia
ach, to tylko zarys mo� liwo� ci jakie daje nam 

SOFTIMAGE XSI. Ale te�  takie by
o zamierzenie niniejszej pracy – wykaza�  na prostych 

przyk
adach 
atwo��  obs
ugi interfejsu, zach� ci�  do dalszego poznawania i tworzenia wed
ug 

w
asnej wizji i wyobra	 ni mniej lub bardziej rozbudowanych obiektów trójwymiarowych.  
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